Проблем със сайта

mishobehar
Мнения: 1286
Регистриран: 30 апр 2007, 15:06

Re: Проблем със сайта

Мнение от mishobehar » 28 апр 2020, 23:32

nomercy написа:
28 апр 2020, 21:46
това е защото не ти е премасочвало към без www версията. не знам mishobehar как е правил птенасочванията.
Понеже виждам, че имаш познания по системно администриране, ето и в htaccess как съм направил пренасочванията:

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

То от това по-ясно няма как да е..

Но направих една донастройка на Апаче-то, мисля, че вече няма да има драма.

За съжаление нямам iOS устройства под ръка, за да тествам :(

ne4o
Мнения: 582
Регистриран: 08 фев 2009, 09:27

Re: Проблем със сайта

Мнение от ne4o » 29 апр 2020, 09:00

Всичко е наред през Safari, след като си направих нова отметка. Зареждайки през старата, пак дава грешка, ако това ви е полезно като информация.

nomercy
Мнения: 173
Регистриран: 12 юни 2008, 18:08

Re: Проблем със сайта

Мнение от nomercy » 29 апр 2020, 13:06

Грешката ще ти излезне и със seamonkey и firefox само че ако искаш да отвориш:
https://www.mobilebulgaria.com/
в горния redirekt не пренасочваш ако е HTTPS с www ,за това така става.
Само , че може да влезнеш в loop така , че най просто ще ти е да издадеш letsebcrypt и на www-to и да го вкараш като Server Alias според мен. Освен ако не държиш всичко да ходи само на https://mobilebulgaria.com

mishobehar
Мнения: 1286
Регистриран: 30 апр 2007, 15:06

Re: Проблем със сайта

Мнение от mishobehar » 29 апр 2020, 15:50

Така.. Адрес https://www.mobilebulgaria.com никога не е съществувал. Минахме от http://www.mobilebulgaria.com директно на https://mobilebulgaria.com/ Но аз пак съм оставил сертификата да се подновява с letsencrypt, въпреки, че тези адреси не се използват и никога не са и съществували.

Подозирам, че някои браузъри могат да пробват линк който е http:// да го заменят без да питат с https://, когато да, възможно е да дава (на мен ми дава грешка с curl https://www.mobilebulgaria.com), но например в нито един браузър не ми е давало този проблем, дори когато собственоръчно напиша в адресбара https://www.mobilebulgaria.com, понеже има редирект да маха www освен в htaccess файла, така и от кода на сайта прехвърля с 301 към без-www, където има сертификат.

@nomercy - на теб дава ли ти го този проблем?

MEnergy
Мнения: 350
Регистриран: 20 май 2010, 23:00

Re: Проблем със сайта

Мнение от MEnergy » 29 апр 2020, 20:36

Прикачвам скрийншот от производен на Файърфокс браузър на десктоп. И в момента зарежда по същия начин и със същата грешка.

При зареждане само на mobilebulgaria.com или https://mobilebulgaria.com грешка изглежда няма, но не съм пробвал със затваряне на браузъра и отваряне абсолютно наново. Явно редайрект-ът не маха www и http или *S се прехвърля чрез www.mobilebulgaria.com, който както казваш - не съществува на теория - но на практика се достъпва.

Като цяло при предишни уебсайтове, за които съм отговарял, сертифицирахме абсолютно всички адреси, вкл. и цялата мрежа от www. Да, повечето хора не добавят http/www/httpS преди mobilebulgaria, но при достъпването им в зависимост от браузъра и други фактори, явно не се зарежда краткия домейн или прехвърлянето не работи правилно.
Нямате нужните права за да преглеждате прикачените към това мнение файлове.

mishobehar
Мнения: 1286
Регистриран: 30 апр 2007, 15:06

Re: Проблем със сайта

Мнение от mishobehar » 29 апр 2020, 21:40

Направих една донастройка. Може ли да видиш пак? Аз съм с Firefox и цял ден си блъскам главата и не мога да я пресъздам тази грешка :(

MEnergy
Мнения: 350
Регистриран: 20 май 2010, 23:00

Re: Проблем със сайта

Мнение от MEnergy » 30 апр 2020, 15:35

В момента съм в движение, но на смартфона нямам грешка, което вероятно означава, че редайректът работи правилно.

Като цяло, проблемът започна преди няколко дни/седмица, което означава, че нещо е пипнато/променено тогава.

monster789
Мнения: 65
Регистриран: 19 ное 2017, 10:18

Re: Проблем със сайта

Мнение от monster789 » 11 юли 2020, 06:35

Мислех си, че форумът няма накъде повече да се развали, но се оказа, че греша. Последните 2 седмици от главната страница на форума изчезнаха темите с новите постове, което беше много удобно. Сега трябва първо да отвориш подтема/директория и да видиш новите теми/постове...

Потребителски аватар
Вито
Мнения: 5061
Регистриран: 09 яну 2008, 01:07

Re: Проблем със сайта

Мнение от Вито » 11 юли 2020, 09:46

Няма такова нещо.
Изображение
SAMSUNG Note 10 Plus Black
HUAWEI Mate 10 Pro Blue
NOKIA 808 PureView Black

Отговори